本文作者:Jackey

DedeCMS错误(PHP 5.3 and above)php.ini

Jackey 5个月前 ( 07-08 ) 209 抢沙发
DedeCMS错误(PHP 5.3 and above)php.ini摘要: 安装了DedeCMS 5.7 SP1,访问后台的时候发现报出错误:“DedeCMS Error: (PHP 5.3 and above) Please set 'reque...

安装了DedeCMS 5.7 SP1,访问后台的时候发现报出错误:

“DedeCMS Error: (PHP 5.3 and above) Please set 'request_order' ini value to include C,G and P (recommended: 'CGP') in php.ini,more...”

解决办法1:

这个错误其实已经在报错的时候提示解决办法了,在PHP 5.3以上版本,增加了一个request_order配置项,默认值为“GP”。DedeCMS认为默认配置有一定风险,所以建议修改成“CGP”就可以了。

解决办法:

找到PHP目录下的php.ini文件,找到request_order配置项,将之前的:

request_order = "GP"

修改为:

request_order = "CGP"

然后重启Apache或者IIS就可以了。路径一般是:

/usr/local/php/etc/php.ini

解决办法2:(针对虚拟主机用户,无法修改php.ini的用户)

找到文件: 

include/common.inc.php

找到34行:

if(strtoupper(ini_get('request_order')) == 'GP')

 修改成:

if(strtoupper(ini_get('request_order')) == 'CGP')

搞定。

文章版权及转载声明

作者:Jackey本文地址:https://u.nf/wz/49.html发布于 5个月前 ( 07-08 )
文章转载或复制请以超链接形式并注明出处UNF站长网

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏

阅读

发表评论

快捷回复:

评论列表 (暂无评论,209人围观)参与讨论

还没有评论,来说两句吧...